Wednesday, August 7, 2013

Stuck Index for FAST Search in SharePoint 2010

The Problem

Here was the situation: my fast search crawl seemed to be running fine. There were no crawl errors reported in Central Admin under the crawl content sources listed under the FAST Connector. However, I was not getting any results dated after Jan 12, 2013 (at the time of this post is it August 2013). Obviously something was wrong. I uploaded a new document within a document library. I ran an incremental crawl. I could see in CA that the document was crawled, but again when I searched for that document on the site, my new document did not return in the results.
I reset the index and still no luck. I’ve been working on this off and on for a while now. Finally tonight, I was successful in discovering the answer.
My index was stuck! Here’s how to find out if your index is stuck.

Determine If Your Index is Stuck

On your FAST server, open a CMD prompt, Within the directory for your FAST install, there are some tools to help you. In CMD, type c:\FASTSearch\bin\indexerinfo status (this is the default install location, yours may be different.  You will get some xml output. The important line is near the top and will say something like
 documents indexed="0" not_indexed="692711" size="721755503316.000000" total="692711"

Notice the part in that line about “not_indexed.”  So even though my crawl was good, my index was stuck.

Resume and Reset Indexing in CMD

Next step is to run the following in CMD (use the location of your FAST install, default is shown below):
C:\FASTSearch\bin\indexeradmin resumeindexing
This works for some people to get the index unstuck. But that didn’t work for me. Next step, in CMD:
C:\FASTSearch\bin\indexeradmin resetindex
Running this line made it so that all of a sudden I had NO results coming back for searches. Yikes!!

Reset and Clear the Index in Central Admin

So I cleared out the index with the following steps:
1.       Make sure the account performing this is a service application administrator for the FAST Content SSA

2.       Go to Central Admin à Application Management à Manage Service Apps

3.       Click the FAST Content SSA

4.       On the Search Administration Page under Crawling, click Index Reset

5.       Click OK

Before any new crawls are started you must manually clear the content from the content collection.
1.       Log onto your FAST server

2.       Open the Microsoft FAST Search Server 2010 for SharePoint shell as administrator

3.       Type the following command

Clear-FASTSearchContentCollection –Name sp*

4.       Wait for it to finish, it will most likely take quite a bit of time. 

*The name of the content collection could vary. To get the name of your FAST search content collection, in FAST powershell type
Voila! Success! I have results and they are current now. Yay!


No comments:

Post a Comment